mirror of https://github.com/sipwise/www_admin.git
You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
39 lines
756 B
39 lines
756 B
#!/bin/sh
|
|
|
|
set -e
|
|
|
|
# don't do anything when called with other argument than configure
|
|
case "$1" in
|
|
configure)
|
|
;;
|
|
abort-upgrade|abort-remove|abort-deconfigure)
|
|
exit 0
|
|
;;
|
|
*)
|
|
echo "postinst called with unknown argument \$1'" >&2
|
|
exit 1
|
|
;;
|
|
esac
|
|
|
|
# enable required modules
|
|
a2enmod ssl perl
|
|
|
|
# enable optional modules
|
|
a2enmod dump_io || echo "Missing some optional Apache module(s), ignoring."
|
|
|
|
# disable debian's default Apache site
|
|
if [ -e /etc/apache2/sites-enabled/default ]; then
|
|
a2dissite default
|
|
fi
|
|
|
|
# reload perl and/or apache modules
|
|
if [ -x /etc/init.d/apache2 ]; then
|
|
if [ -x "`which invoke-rc.d 2>/dev/null`" ]; then
|
|
invoke-rc.d apache2 restart || true
|
|
else
|
|
/etc/init.d/apache2 restart || true
|
|
fi
|
|
fi
|
|
|
|
exit 0
|