You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rtpengine/debian/ngcp-rtpengine-kernel-dkms....

25 lines
419 B

#!/bin/sh
set -e
if [ -x "$(which ngcp-virt-identify)" ]; then
if ngcp-virt-identify --type container; then
VIRT="yes"
fi
fi
#DEBHELPER#
if [ "$VIRT" = "yes" ]; then
echo "Container environment detected. Skip daemon"
else
if [ "$1" = 'configure' ] ; then
# try to start the daemon
if [ -x /etc/init.d/ngcp-rtpengine-daemon ] ; then
invoke-rc.d ngcp-rtpengine-daemon restart || true
fi
fi
fi
exit 0