mirror of https://github.com/sipwise/repoapi.git
31 lines
660 B
31 lines
660 B
#!/usr/bin/make -f
|
|
|
|
# Uncomment this to turn on verbose mode.
|
|
#export DH_VERBOSE=1
|
|
|
|
export HOME=$(CURDIR)/$(BUILDDIR)
|
|
|
|
%:
|
|
dh $@
|
|
|
|
override_dh_auto_test:
|
|
|
|
override_dh_auto_build:
|
|
# fake files needed to deploy
|
|
cp debian/secret_key .secret_key
|
|
cp debian/server.ini server.ini
|
|
|
|
override_dh_auto_install:
|
|
VAR_DIR=$(CURDIR) make deploy
|
|
find . -name '__pycache__' -type d -print0 | xargs --no-run-if-empty -0 rm -r
|
|
make clean
|
|
|
|
execute_after_dh_fixperms:
|
|
chown www-data:www-data debian/repoapi/var/lib/repoapi
|
|
|
|
override_dh_installsystemd:
|
|
dh_installsystemd --name=repoapi-worker
|
|
dh_installsystemd --name=repoapi-flower
|
|
dh_installsystemd --name=repoapi-beat
|
|
|